
Part 1: Heat Conduction in Breast 
 
 
 
Step 1: Problem Type Specification 
 

(1) Open COMSOL Multiphysics 4.1. 
(2) Under Select Space Dimension, 

select 2D axisymmetric. 
(3) Click on blue arrow next to 

Select Space Dimension title. 
(4) Click left of Heat Transfer to 

expand the option. 
(5) Click on Heat Transfer in Solids 

(ht) 
(6) Click on blue arrow next to Add 

Physics title. 
(7) Click on Time Dependent. 
(8) Click on the race flag icon to 

finish. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
 



Step 2: Geometry Creation 
 

(1) Right click on Geometry 1. 
(2) Select Circle. 
(3) Repeat (1) & (2) two more 

times. 
(4) Select Geometry 1 > Circle 1 and 

enter the radius as 51.5e-3 
(5) Click on the Build All icon. 
(6) Select Geometry 1 > Circle 2 and 

enter the radius as 56.5e-3 
(7) Click on the Build All icon. 
(8) Select Geometry 1 > Circle 3 and 

enter the radius as 5e-3 
(9) Set the base to Center and r to 0 

and z to -45.5e-3  
(10)Click on the Build All icon. 
(11)Right click on Geometry 1. 
(12)Select Rectangle. 
(13)Set Width to 113e-3 

                   Height to 68e-3 
(14)Set r to -56.5e-3 
             z to -11.5e-3 
             for Corner. 

(15)Click on Build All icon. 
 

 
 
 
 
 

 
 
 

 
 



 
(16)Right click on Geometry 1. 
(17)Select Boolean Operations > 

Compose 
(18)Type c1+c2+c3 in Set formula 

input. 
(19)Click on Build All icon. 
(20)Right click on Geometry. 
(21)Select Boolean Operations > 

Compose 
(22)Type co1-r1 in Set formula 

input. 
(23)Click on Build All icon.  
(24)Right click on Geometry and 

select Rectangle. 
(25)Set Width and Height to 56.5e-

3 
(26)Set Base to Corner, r and z to -

56.5e-3 
(27)Click on Build All icon. 

 

 
 



(28) Right click on Geometry 1. 
(29)Select Boolean Operations > 

Compose 
(30)Type co2-r2 in Set formula 

input. 
(31)Click on Build All icon. 
(32)Right click on Geometry 1 and 

select Transforms > Move 
(33)Left click then right click on 

co3. 
(34)Set z to 56.5e-3 under 

Displacement. Make sure the 
entire geometry is selected 
(shown in blue) before it is 
moved. 

(35)Click on Build All icon. 
(36)Click on Zoom Extents icon.  

 
 
 
 
 
 
 
 
 
 
 
 
 



Step 3: Meshing 
(1) Right click on Mesh 1 and 

select Free Triangular. 
(2) Right click on Free Triangular 1 

and select Size. 
(3) Under Predefined mesh 

element size, select Finer. 
(4) Click on Build All icon. 

 

 

 
 
 
 
 
 
 



 
Step 4: Conduction—governing 
Equations, source terms, I.C., B.C. 
 
A. Subdomain settings 
 

(1) Click on Heat Transfer (ht) > 
Heat Transfer in Solids 1 

(2) Select User defined for k, ρ, Cp 
and enter the values for 
Subdomain 1 from the table 
below. 

Subdomain 1 2 3 
k 0.22 0.48 0.48 
Ρ 930 1050 1050 

Cp 2770 3770 3770 
(3) Right click on Heat Transfer 

(ht) and select Heat Transfer in 
Solids 

(4) Left click then right click on 
subdomain 2. 

(5) Enter the corresponding k, ρ, 
Cp values from the table. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



(6) Right click on Heat Transfer 
(ht) and select Heat Transfer in 
Solids 

(7) Left click then right click on 
subdomain 3. 

(8) Enter the corresponding k, ρ, 
Cp values from the table. For 
reference, Heat Transfer in 
Solids 1 will now look like the 
following: 

(9) Right click on Heat Transfer 
(ht) and select Heat Source. 

(10) Repeat (9) two more times. 
(11) Select Heat Transfer (ht) > 

Heat Source 1 and left click, 
right click on Subdomain 1. 

(12) Set Q to user defined and 
enter src_fat 

(13) Repeat (11) & (12) for Heat 
Source 2 and 3 

Heat 
Source 

Subdomain Q 

2 2 src_gland 
3 3 src_tumor 

 

 
 
 



Initial Condition 
(14)  Click on Heat Transfer (ht) > 

Initial Values 1 
(15) Enter 310.15K for To. 
 
B. Boundary settings 
 
(16) Right click on Heat Transfer 

(ht) and select Heat Flux. 
(17) Left click then right click on 

boundary 7. 
(18) Select Inward heat flux and 

enter 458 for h and 283.15 for 
Text. 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Step 5: Define Expressions 

(1) Click on left of Model 1 to expand the option. 
 

(2) Right click on Definition and select Variables. 
 

(3) Click on a table entry and define the following expressions. 
Name Expression 
src_fat 800*(310.15-T)+400+100*1.3e4*exp(-100*z)*(r<=0.005) 
src_gland 2400*(310.15-T)+700+100*1.3e4*exp(-100*z)*(r<=0.005) 
src_tumor 48000*(310.15-T)+65400+100*1.3e4*exp(-100*z) 
Note here that all the heat source terms have three components: blood 
perfusion, metabolic heat generation, and laser heating. The laser does not 
act beyond a radius of 0.005m in the subcutaneous fat and gland layer and 
hence, the logical expression (r<=0.005) is used in the equation with the 
laser heating term. The expression, r<=0.005, returns 1 if it is true, i.e., if r is 
less or equal to 0.005, and 0 otherwise. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Step 6: Solver settings and Solution 
 

(1) Click left of Study 1 to expand 
the option. 

(2) Select Step 1: Time Dependent. 
(3) Type range (0,1,1200) in the 

Times edit field. 
(4) Click on Study 1 > Solver 

Configurations > Solver 1 > 
Time-Dependent Solver 1. 

(5) Expand the ‘Time Stepping’ tab. 
(6) For Steps taken by solver, open 

the drop-down menu and 
select ‘Strict’. 

(7) Right click on Study 1 and 
select ‘Compute’. 

 
 

 
 
 
 

 
 
 

 
 

 
 

 



 
Step 7: Postprocessing 
 

(1) Right click on Data Sets under 
Results. 
 

(2) Select Evaluation > Integral. 
 

(3) Right click on Integral 1 and 
select Add Selection. 
 

(4) Left click then right click on 
subdomain 3. 
 

(5) Right click on Results and 
select 1D Plot Group. 

 
(6) Under the Data tab, select 

‘Integral 1’ from the drop-
down menu of ‘Data set:’ 

 
(7) Under the Plot Settings tab, 

check the boxes for x-axis label 
and y-axis label. Then type in 
Time for x-axis label and 
Average Tumor Temperature 
for y-axis label. 

 
(8) Expand the Axis tab and check 

‘Manual axis limits’. Enter 0 for 
x minimum, 1200 for x 
maximum, 310 for y minimum, 
316 for y maximum. 
 

(9) Right click on 1D Plot Group 2 
and select Global 
 

 

 

 
 



(10) Click on a table entry and 
enter 
2*pi*r*T/(4/3*pi*0.005^3) 
under Expression edit field. 
2*pi*r is multiplied to T 
(temperature) as the 
problem is axisymmetric and 
therefore we want to 
calculate the volume integral. 
The value of the integral is 
divided by the volume of the 
tumor (4/3*pi*0.005^3), 
represented as a sphere. 

(11) Click on Plot icon. 
(12)   Right click on Global 1 and    

   select Add Plot Data to Report 
(13) Click on Browse button. 
(14) Enter a file name and save. 
(15) Click on Export icon. 

 

 

 

 
 

 
 

 
 

 



 
 
Step 8: Calculations for subsequent analysis 
 
The calculations shown here are performed on Microsoft Office Excel. Any other spreadsheet 
application or code can also be used. 
 

(1) Open the average temperature file in Notepad++ (or you can work with WordPad as 
well). It should look like this: 

 
The numbers on the left indicate the time (there should be up to 1200) and the ones on 
the right are the average tumor temperatures. 
 
(1) Use a spreadsheet application such as Microsoft Excel and import the data from the 

text file so that the times are listed in one column and the corresponding 
temperatures in another column to the right. 
 

(2)  
 

 
 



For the column next to temperature values, calculate the radius as a function of time 
given by the equation:  

𝑟 = 𝑟𝑜�𝑒𝑏(𝑇−𝑇𝑜) 
where 

ro=6e-6 
b=0.1 if the average temperature is less than 315.15K and -0.1 if greater than 310.15K 

To=310.15K 
 
This can be done by using the following function formula:  

=0.000006*SQRT(EXP(0.1*(B1-310.15))) 
for cell C1 for example. 

 
(3) Calculate the change in radius for consecutive times. For example, if the radius at 

time 0 is 6e-6 and radius at time 1 is 6.04e-6, then the change in radius for the first 
time interval is 6.04e-6 − 6e-6 = 0.4e-6. *Note here that the change in radius is also 
equal to the velocity with which the radius changes, since the time interval is 1s. 
This can be done by using the following function formula: 

=C2-C1 
for cell D2. Enter 0 for the change in radius for time 0. 

(4) Now the column A shows the times, B indicates the average tumor temperatures, C 
has the calculated radii values, and D has the change in radius in different time 
invervals. 

(5) The last step is to create a text file that contains the velocity of radius change as a 
function of time which can be used in COMSOL. The format of the file is: 

%time 
Time values separated by spaces 
%velocity 
Velocity values separated by spaces 

 
 
(6) The above format can be created using Excel: 

Copy the data in a column > Paste Special > Select Paste Values and Transpose. 
(7) Copy the values from Excel into an empty Notepad++ or WordPad file and create 

the file as shown above by typing %time and %velocity at appropriate places. 
Remember to make sure that there are no line breaks between data; otherwise the 
file cannot be used in COMSOL. 
 



 
 

Part 2: Navier-Stokes and Transient Convection-Diffusion 
 

Step 1: Problem type specification 
(1) Open COMSOL Multiphysics 4.1 
(2) Select 2D axisymmetric 
(3) Select Fluid Flow > Single-Phase Flow > Laminar Flow (sdf) 
(4) Click on ‘+’ button. 
(5) Select Chemical Species Transport > Transport of Diluted Species (chds) and click on + 

button. 
(6) Select Mathematics > Deformed Mesh > Moving Mesh (ale) and click on + button. 
(7) Click on blue arrow button 
(8) Select Time Dependent 
(9) Click on race flag button 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Step 2: Geometry Creation 

(1) Right click on Geometry 1 and select Rectangle 
(2) Set Width to 6e-6 and Height to 100e-6, Base to Corner and r & z to 0.  
(3) Click on Build All icon. 
(4) Repeat (1) 
(5) Set Width to 54e-6 and Height to 100e-6, Base to Corner and r to 6e-6 and z to 0. Click 

on Build All icon. 
(6) Click on Zoom Extents button to fit the geometry into window. 

 
 
Step 3: Meshing 

(1) Right click on Mesh 1 and select Mapped. 
(2) Right click on Mesh > Mapped 1 and select Distribution. 
(3) Repeat (2) two more times. 
(4) Select Distribution 1. Left click then right click on boundaries 1,4,7. Enter 20 for Number of 

Elements. 
(5) Select Distribution 2. Left click then right click on boundaries 2, 3. Enter 10 for Number 

of Elements. 
(6) Select Distribution 3. Left click then right click on boundaries 5, 6. Enter 60 for Number 

of Elements. 
(7) Click on Build All icon. 
(8) Your mesh now looks like the figure on the following page. 

 

 
 
 



 

 
 
 
 
Step 4: Moving Mesh—governing equations, source terms, IC, BC 
 
Subdomain settings 
 

The default values of subdomain settings are retained for Moving Mesh (ale) 
application mode and only the boundary settings are changed. 

 
Boundary settings 

 
 

(1) Right click on Moving Mesh (ale) and select 
Free Deformation 

(2) Select all subdomains by left click, right 
clicking on them. 

(3) Right click on Moving Mesh (ale) and select 
Prescribed Mesh Displacement 

 

 
 
 



 
(4) Left click, right click on boundaries 2,3,5,6. 
(5) Uncheck Prescribed r displacement. This is so 

that the mesh is free to move in the r 
direction. 

(6) Set Prescribed z displacement to 0. 
(7) Right click on Moving Mesh (ale) and select 

Prescribed Mesh Velocity. 
(8) Left click, right click on boundary 4. 
(9) Enter vel(t) for Prescribed r displacement. 

This will incorporate the velocities calculated 
earlier and saved in velocity.txt file. 

(10) Set Prescribed z displacement to 0. 
(11) Select Prescribed Mesh Displacement 1 and 

make sure that boundaries 1 and 7 have 
Prescribed r, z displacements of 0 (default 
value). 

 
 

Step 5: Laminar Flow—governing equations, 
source terms, IC, BC 
 
Subdomain settings 

(1) Click on Laminar Flow (spf) 
(2) Click on subdomain 2 and remove it by 

clicking on the – button. 
(3) Click on Laminar Flow (spf) > Fluid 

Properties 1 
(4) Set ρ and μ to User defined and enter 1100 

and 0.0044, respectively. 
Boundary settings 

(5) Right click on Laminar Flow (spf) and select 
Inlet 

(6) Left click then right click on boundary 2. 
(7) Change boundary condition to Pressure, no 

viscous stress and enter 2307 for po. 
(8) Right click on Laminar Flow (spf) and select 

Outlet 
(9) Left click then right click on boundary 3. 
(10) Make sure boundary condition is set to 

Pressure, no viscous stress and enter 1160 
for po. 

(11) Select Laminar Flow (spf) > Wall 1 
(12) Make sure for boundary 4, the boundary 

condition is set to No slip. 



 
 
Step 6: Convection and Diffusion—governing 
equations, source terms, IC, BC 
 
 Subdomain Settings 

(1) Select Transport of Diluted Species (chds) > 
Convection and Diffusion 1 

(2) Set Diffusion coefficient Dc to 1.5e-9 
(3) Right click on Transport of Diluted Species 

(chds) and select Reactions 
(4) Left click then right click on domain 2  
(5) Enter -1.1*(c>0)+0*(c<=0) for Rc. 

Boundary Settings 
(6) Right click on Transport of Diluted Species 

(chds) and select Concentration 
(7) Left click then right click on boundary 2 
(8) Check ‘Species c’ and set C0,c to 50 (mol/m3). 
(9) Right click on Transport of Diluted Species 

(chds) and select Outflow 
(10) Left click then right click on boundary 3 



 
 
Step 7: Define function 
The function vel(t) used earlier needs to be defined 
before the problem is solved. 

(1) Right click on Global Definitions and select 
Functions > Interpolation 

(2) Change Data source to File  
(3) Browse for the text file in which you saved 

the velocity data earlier on. 
(4) Click on Import 
(5) Now the Data source is changed to Table and 

the two columns below have the time values 
and velocity values listed. 

(6) Change the Function name to vel 

 



 
Step 8: Solver settings and solution 

(1) Right click on Study 1 and select Study Steps 
> Stationary 

(2) Right click on Step 2: Stationary and select 
Move Up. 
Now the step orders of Time Dependent and 
Stationary are switched (Stationary is Step 1, 
Time Dependent is Step 2).  

(3) Select Step 1: Stationary 1 
(4) In the Physical Selection > Physics interfaces 

list, click on Moving Mesh (ale) and uncheck 
Use for this study. 

(5) Right click on Study 1 and select Show 
Default Solver. 

(6) Select Solver Configurations > Solver 1> 
Dependent Variables 2. 

(7) In the ‘Initial Values of Variables Solved For’ 
tab, make sure ‘Method’ is set to Solution, 
‘Solution’ to Solver 1, and ‘Use’ to Current. 
This is done so that the initial conditions for 
Laminar Flow (spf) and Transport of Diluted 
Species (chds) application modes are taken 
from the steady-state (stationary) solution. 

 
 
 



(8) Select Solver Configurations > Solver 1> 
Time-Dependent Solver 1. 

(9) Under the ‘Time Stepping’ tab, select Strict 
for the ‘Steps taken by solver’ drop-down 
menu. 

(10) Select Study 1> Step 2: Time Dependent 
(11) Type range (0,1,1200) for Times edit field. 
(12) Right click on Study 1 and select Compute 

 
The computation takes around 15 minutes. 
 

 
 
Step 9: Postprocessing 

(1) Right click on Results and select 2D Plot 
Group. 

(2) Right click on 2D Plot Group 2 and select 
Contour. 

(3) Click on the double arrow button next to 
Expression tab title and select Transport of 

Diluted Species > Species c > Concentration 
(c). 

(4) Under ‘Levels’ tab, select Levels for Entry 
method and enter range(27,3,48) for Levels 
edit field. 

(5) Under ‘Coloring and Style’ tab, check Level 
labels box. 

(6) Click on Plot icon. 
(7) Click on Zoom Extents and the contour plot, 

which looks like the picture below. 

 


